it-swarm-korea.com

Drupal 6 지원되지 않는 보안 상태가 유지됩니까?

Drupal 6 + Views + CCK 사용하여 사용자 지정 데이터베이스 인터페이스를 만들었습니다. 회사와 최근에는 다른 서버로 마이그레이션해야했습니다.

나는 "이봐, 왜 Drupal 7을 설치 한 다음 데이터베이스를 덤프하지 말아야한다고 생각했다.) 그러면 업그레이드 할 수있다 Drupal 마이그레이션하는 동안 최신 버전으로 업그레이드 하시겠습니까?! "

그것은 나쁜 생각으로 밝혀졌습니다. Drupal 7은 내가 준 DB 정보와 관련하여 약간의 단서가없는 것 같습니다. 지금 업그레이드 가이드는 시간이 많이 걸리는 것 같습니다.

내 질문은 : Drupal 6 지원되지 않는 안전한 상태로 남아 있습니까? 아니면 플랫폼이 더 이상 사용되지 않고 취약하여 더 많은 업그레이드를 강요합니까?

8
Garrett

뷰와 같은 주요 기여 모듈 중 일부는 알파가 아닌 안정적이고 Drupal7 모듈을 가질 때까지, 나는 drupal6이 앞으로 한동안 사용될 것이라고 생각합니다.

Drupal6 사이트가 많이 있기 때문에 drupal6이 앞으로 몇 년 동안 지원 될 것이라고 확신합니다.

대답은 아니오입니다. 업그레이드 할 필요가 없습니다.

8
Camsoft

Drupal 8이 나오면 Drupal 6은 "삶의 끝"으로 표시됩니다) : Drupal 보안 팀이 중지합니다) 새로운 보안 취약점이 발견되면 직접 패치해야하므로 그 시점에서 업그레이드하면 큰 도움이됩니다.

그러나 Drupal의 업그레이드 경로는 이전 버전에서 현재 버전으로입니다. 즉, 업그레이드 경로는 Drupal 6에서 = Drupal 7, 그리고 업그레이드 경로는 Drupal 7에서 Drupal 8)로 제공됩니다.).

Drupal 6에서 Drupal 8 :)에 대한 업그레이드 경로는 없습니다. Drupal 8이 나오면 먼저 Drupal 6 사이트를 Drupal 7, 7으로 업그레이드 한 다음 Drupal 8.

그래서 그것은 경제와 장기 계획에 달려 있습니다. Drupal 6은 Drupal 8까지 지원되지만, Drupal 8이 몇 년 후에 나올 때) 사이트를 다시 쓸 수있는 기회가 없다면 나중에 Drupal 7)로 업그레이드해야합니다.

15
user7

항상 두 가지 버전의 Drupal 동시에 지원됩니다. 따라서 Drupal 8이 해제 될 때, Drupal 6 지원 될 때까지 남은 시간이 있으므로 서두를 필요가 없습니다.

충분한 수의 사람들이 보안 버그 패치를 계속 기꺼이 허용하면 더 이상 공식적으로 지원되지 않더라도 계속 안전하게 사용할 수 있습니다. 보안 패치로 무기한 Drupal 6 6을 계속 지원할 수있는 사람이라면, 충분한 사람들이 그 일에 관심이 있는지 여부입니다. Drupal = 6 Drupal 8의 공식 릴리스 이후에도 계속 지원됩니다.

4
Mad Scientist

원래 문제는 사이트를 업그레이드하는 데 많은 시간을 소비하고 싶지 않다는 것입니다.이를 잘 이해할 수 있지만 업그레이드를 수행하는 것이 좋습니다. 몇 가지 이유 :

  • 조만간 Drupal 6이 가까워짐에 따라) 수명 종료 로 인해 업그레이드 해야합니다. .
  • Drupal 사이트로 작업하는 경우, 주요 업그레이드를 수행하는 방법을 배우면 큰 도움이됩니다. 나와 같은 많은 사람들이 Drupal 6 , 이것이 우리가 적용 할 수있는 첫 번째 업그레이드입니다. 이것은 소중한 지식입니다.
  • 핸드북에 기록 된 업그레이드 프로세스를 "변경"할 수 있습니다-nobody해야 할 일 예를 들면 ... 내가 당신이라면, 몇 시간을 준비하고, 모듈과 테마를 확인하고, 코어 등을 확인하고, 다음 날에는 업그레이드를 진행할 것입니다. 테스트 환경. 이렇게하면 좀 더 편안해집니다. 가장 중요한 것은 모든 것을 기록하는 것입니다 . nothing 기록하는 것보다 클릭 할 때마다 문서를 작성하는 것이 좋습니다. 이것을 즐기면서 업그레이드 된 사이트가 그 어느 때보 다 나아질 것입니다!

그리고 우리는 많은 에너지와 지원을 제공하는 거대한 커뮤니티를 가지고 있으므로 당신이하는 일에 대해 이야기하고 블로그 게시물이나 무언가를 쓰십시오 -누군가는 아마 당신 에게서도 큰 혜택을 볼 수 있습니다.

2
Scorchio

새로운 Drupal 버전이 나오면 새 빌드를 이전 버전과 "이전 버전과 호환"하려는 시도는 없습니다. "CCK"모듈이 Drupal의 핵심 기능 중 하나라는 사실을 포함하여 몇 가지 기본 사항이 Drupal 7로 변경되었습니다. 따라서 권장되는 업그레이드 절차 를 따르지 않으면 Drupal 7 설치는 Drupal 6 데이터베이스로 수행 할 작업을 알 수 없습니다. (그렇더라도 모듈을 사용자 정의하거나 고유 한 모듈 또는 템플릿을 작성한 경우 응용 프로그램을 완전히 변환하기 위해 몇 가지 작업을 수행해야합니다.)

즉, 적어도 지금은 업그레이드 하지 않습니다. 다른 사람들이 지적했듯이 Drupal 8이 나올 때까지 Drupal 6을 계속 사용하는 것이 좋습니다. 자체 하드 드라이브의 MAMP 또는 WAMP 설치에서 병렬 Drupal 7 서버를 실행하고이를 사용하여 응용 프로그램을 Drupal 7로 포팅하는 연습을 할 수 있습니다. Drupal 8이 나오면, 응용 프로그램을 Drupal 7로 업그레이드 할 준비가되어야합니다 (그리고 설치 한 다른 모듈은 그때까지 D7을 따라 잡았어야합니다).

1
JR Dixey